cMT X Series Easyweb 2.0
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L_l\u\WE!NTEK cMT X Series Easyweb 2.0

Chapter 1 System Settings

1.1 Overview

Easyweb 2.0 is a web interface that allows users to configure parameters of cMT X Series HMI.
Additionally, with its Webview feature, users can monitor HMls through a web browser. This user

manual explains the cMT X Series HMI features that can be configured using Easyweb 2.0.

1.2 Ways to Log In Easyweb 2.0

Connect an HMI via an Ethernet cable, and log in system settings in one of the following ways.

Via internet browser

Open internet browser (Windows Edge, Chrome, or Firefox), and enter HMI’s IP address (e.g.:
192.168.2.121). The web page below opens. If Webview interface is shown after entering the IP
address, please enter https://HMI_IP/admin to open Easyweb 2.0 system login page.

W Easyweb

Welcome back

Sian ) con
Sign in to continue

£ HM! Name

Admin Jpdate History

NG cMT-1E7C_FAE_cMT3072XH .

Password

J et

Set on cMT Viewer devices

Launch cMT Viewer App, tap Search, select the HMI and tap Qe icon to configure.
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https://hmi_ip/admin%20to%20open%20EasyWeb%202.0

o[ f
I 17-03-2910:4806 -

Connect °
Search History

Q Name/ 1P c

-y CMT-4C66

“ 192,168.2.121 [+

-, Default HMI

B

"7 192.168.2.124 ° |
. CMT-3E87

2

“ 192.168.2.127 °

o 1%-3072

¥ 192.168.2.136 e

o, CMT-4C52

5y

v 192.168.2.141 e l
-, CMT-2C40

¥ 192.168.2.147 ©

.~ Default HMI

“* 192.168.2.151 6 l
7, CMT-04B1

"7 192.168.2.195 e

o CMT-AC51%Q 2

' 192.168.1.212 -

1.3 Easyweb 2.0 Login Identities

Three identity levels exist in Easyweb 2.0: [Admin], [Update], and [History]. [Admin] controls all the
settings while [Update] controls limited items. For safety, specify a password before configuration.
A password is needed for opening [History] settings, and the historical data can be backed up after
logging in with password.

The default password is 111111. After successful login, the password for each identity level can be

changed in [System Password] page.

W Easyweb

Welcome back
Sign in to continue

a ®

Admin Update History

Password
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1.4 Easyweb 2.0 Interface
Dashboard

System status and HMI status are displayed in Dashboard after login.

192.168.2.97

\\o cMT3072XH HMI Name: Date/Time:
EasyWeb 2.0
© sveen Dashboard
T3 Network
= Project
2023/04/27 15:28:31 3:29
& Daa
® Features
V2.1.53 20230322

System » Info

In this page the user can edit HMI Name / Date / Time.

192.168.2.97

\\o cMT3072XH HMI Name: Date/Time:
EasyWeb 2.0
© sveen Dashboard
T3 Network
= Project
2023/04/27 15:28:31 3:29
& Daa
@ reares
V2.1.53 20230322

cMT-1E7C_FAE_cMT...

2.16.5

cMT-1E7C_FAE_cMT...

2.16.5
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System » Diagnostics
In this page the user can collect information about any errors that occur during HMI operation.

192.168.2.97

HMI Name: Date/Time:

“,? cMT3072XH )

) EasyWeb 2.0

Diagnostics

HMI Info Collector Version: 1.0.20
® Diagnostics

¥ Run

T Network HMI Info Collector:

= Project

B hmi-info-collect..enc A

Network » Ethernet

In this page the user can set the IP address of each Ethernet port.

\\0 HMI Name: Date/Time: - admin
)
Ethernet
i ]
=
LAN 1 (WAN)
-

Mac Address: 00:0¢:26:21:1e:7¢

Configure IP: Automatic &
Address: 192 . 168 . 2 . 97
G
Netmask: 255 . 255 . 252 . O
Gateway: 192 168 . 254
DNS: 168 . 9% . 1
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Bridge Mode
Dual Ethernet port models can be configured in Bridge Mode to allow LAN1 and LAN2 to operate in

the same network segment, providing switch-like functionality.

\\" cMT3072XH

HMI Name: Date/Time: ® - admin v
EasyWeb 2.0 ?

Ethernet

o System

T Network

Bridge Mode

® Ethemet
Enable Bridge Mode:

Enabling Bridge Mode triggers a confirmation window, which prompts users to verify the proper
connection of the two Ethernet ports. Failure to do so could lead to a network loop and a broadcast

storm. Once the connection is confirmed, click OK to proceed with the operation.

Attention! X

Bridge mode makes HMI behave like a two-port Ethernet
switch. And networks on both Ethernet ports are
connected in the same broadcast domain.

NOTICE: if both ports connects to the same network,
unplug one. Otherwise, this creates a network loop and
causes a broadcast storm breaking the network.

OK (5) Cancel
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Project » Project Management

In this page the user can restart / update / back up the project file.

@ cMT-Project Management X =+

< C A == | 192.168.2.121/admin/project/management

* a 0@ BEQE 3@ :

® Dashboard / Project Project Management = admin
\ cMT3152X

Easyweb 2.0

QO o

Project Management

] Network Restart Project: Restait C
= Project Update Project:
® Project Management Backup Project: Backup

USB/SD Update:

Project » Email

In this page the user can edit email contacts; e.g., the groups a contact is in, and email addresses.

o= %
@ MT- Email x  +

< C A Fz== | 192.168.2.121/admin/project/email

* 0B BB @ :

® Dashboard / Proect / Emai = admin
\ cMT3152X
== 0
o Inio SMTP Contaots Upload
@ Network
*Host: stmp.gmail.com

i Project

(W) Features

*Username:

* Password:

* Gonfirm Password-

Authentication:

Encryption:

Sender Information

“Name:

test@gmail.com

None Q9 TS SSL

Local HwmI

Use HMI Name
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Project » Enhanced Security

In this page the user can set operable classes and password for each account.

o|=] &
@ cMT - Enhanced Security x  +
< C A F=Z | 192.168.2.121/admin/project/security +« ®% O 1 8| = @ :
® Dashboard / Project / Enhanced Security - admin
\ cMT3152X
Easyweb 2.0
o Info Accounts Impart User Accounts
T Network Add Account Save
Please click [Save] bution after editing data
== Project o ! -
Passwor
D Hide Account a A B [ D E F G H 1
1 admin 11111 ~ ~ ~ 4 N4 N4 v Ve e
@ Enhanced Security 2 useri 111 o
3 user2 222 ~ ~
&= Data 4 user3 333 N v v
@ Features 5 userd 444 v v \/ v
a Account 6 userS 555 v v v v v
7 usert 666 ~ ~ 4 4 N4 v

Import User Accounts
Import the UserAccounts file generated by [Administrator Tools]. If there are duplicate users, the
import will fail. However, the [Reset database] option can be selected to overwrite and import

successfully.

+ - O
192.1 rity : & =88E
HMI Name: clIT-FHOX-FAE Date/Time: 2024/06/04 14:20:10 ® S admin - -

\ © cMT-FHDX-220 ’

EasyWeb 2.0
Enhanced Security
o System

1 Network Account Import User Accounts

= Project Reset database?

®  Enhanced Security

Drop file here or click fo upload

B UserAccounis

Update
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Project » Recipe

In this page the user can update, back up, or clear recipe data on HMI.

o|=] %
@ cMT - Recipe x 4+
<« C A F=2 | 192.168.2.121/admin/project/recipe # ® O | s e @ H
Dashboard / Project Recipe o admin
\‘@ cMT8152X -
Easyweb 2.0

QO o Action
em
@ Network Update Backup

= Project Recipe Database Backup
nw

U

Backup

-

Data » Data Log & Trend Display

This page displays data log and the corresponding trend. The data can be exported or backed up.
Please note that decimal places are not displayed, exported or backed up in Easyweb 2.0; however,
this can be achieved by creating a History Data Display object and a Backup object in the HMI

project and connecting the HMI using cMT Viewer.

UMO020001E_20240807 Copyright© 2023 WEINTEK 1IOT LTD. All rights reserved.
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o|=] %
@ cMT- Datalag & Trend x 4+
< C A F=2 | 192.168.2.121/admin/data/datalog % ® O H g =@ :
b Dashboard / Data / Data log & Trend = admin
Data Log Trend Display
Object:  logooo
0 Refresh @ Option
# = Time + Channel 1 Channel 2 Channel 3
Ll By 235778 (@ 2020/04/0113:27:39 0422618 0574748 1.19927
235777 (© 2020/04/01 13:27:38 -0.173648 -0.777817 1.18177
235776 © 2020/04/01 13:27:37 0.130526 -0.959746 1.09625
235775 © 2020/04/01 13:27:36 0.382683 -1.0587 0.97082
235774 ® 2020/04/01 13:27:35 0.608761 -1.09915 0.802957
235773 ® 2020/04/01 13:27:34 0.793353 -1.07886 0.6
235772 (& 2020/04/01 13:27:33 0.939693 -0.980107 0.330765
* Export to Spreadshest * Backup database 1
o|=] %
@ cMT- Datalag & Trend x 4+
< C A F=2 | 192.168.2.121/admin/data/datalog % ® O H g =@ :
Dashboard / Data / Data log & Trend = admin
\ © cMT3152X
E: b20
Data Log Trend Display
Object:  logooo
Auto Refresh 2 Refresh @ Option
45
Data Log & Trend Display 10
15
0 —
-15
-30
-45
1:23PM 124 PM 1:25 PM 1:26 PM 1:27 PM 1:28 PM 1:29PM 1:30 PM 131 PM
—-0.382683 —— 0914817 ——-12
X. Division 8 Y. Division 7

The display feature can work properly only when in EasyBuilder Pro, [All records in one file] is
selected in Data Sampling’s History File setting. The display feature is currently not supported for
[Customized file handling] mode.
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History file
Enable

@) All records in one file

() Customized file handling

File name :  |ogooo

Data » Event Log

This page displays event logs, and the data can be exported or backed up.

o|=] &
@ MT-Eventlog x  +
& G A F=2 | 192168.2.121/admin/data/eventlog # 4 0[ B =@ :
b Dashboard / Data / Eventlog - admin
Time column
2 Network 2020-03-04 ) 2020-04-01
Category range (0 - 255)
- .
Project
0 255 .

Keywords Select Language

Add terms Language1
EventLog
# Calegory Event Message Event trigger time Retum ip normal time Occurence count
1 1 TankError!! (© 2020/04/01 13:31:25 ® 3 =
2 1 Machine Error !t © 2020/04/01 13:31:25 O 2020/04/01 13:31:31 44
3 255 StartMemory Test  © 2020/04/01 133117 @ 1
Flow Speed Ermor

4 1 . © 2020/04/0118:31112 @ 2020/04/01 13:31:20 17
5 1 Machine Error !t © 2020/04/01 13:31:110 @ 2020/04/01 13:31:18 43
[ 1 TankEmor ! © 2020/04/01 133106 © 20200401 13:31:15 30
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Data » Operation Log

In this page the user can back up operation logs.

@ cMT - Operation Log X  +

< C A F=2 | 192.168.2.121/admin/data/operationLog
\ © cMT3152X
Easyweb 20

o Info
EI Network

Dashboard / Daia Operation Log

+ Backup database

= Project

@ OperationLog

@ Features
@ Account

o= X
* S OB EQ @ :

= admin

Features » Webview Setting

In this page the user can enable Webview and set password. Please see Chapter 2 in this user

manual for more details.

3 HMI Name: D¢ Date/Time:

WebView Setting
Enable
Force HTTPS

@ Features Use same HTTP port as EasyWeb

®  WebView Setting

Use WebView as homepage
User List

Amométnc Logi»n

(?ontrol Us‘er

View User

WebView w

A

8

0 A Control Only View Only

© Disabled Control User View User

Change password

Change password &

UMO020001E_20240807 Copyright© 2023 WEINTEK 1IOT LTD. All rights reserved.
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Features » CODESYS

In this page the user can activate CODESYS® and manage settings for firmware updates.

- o

192.1 % & O @ mncogito

\‘0 cMT3072XH : =
EasyWeb 2.0 3

@ sysen CODESYS

T3 Network

Status

= Project
e g Status: Not Activated

License: Activate Restore

® CODESYS

Features » FTP

In this page the user can modify FTP server related settings.

x  + v

192168213 O @ =rxua

HMI Name: Date/Time: 2 admin
\ © cMT3072XH =
EasyWeb 2.0
o System FTP
Network
Tl Netwo FTP Server Enable [ @)

B Project

&= Data
FTP client can modify USB/SD data
® Features :

FTP port

UMO020001E_20240807 Copyright© 2023 WEINTEK 1IOT LTD. All rights reserved.
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Features » EasyAccess 2.0

In this page the user can activate EasyAccess 2.0 and configure the proxy server.

192.168.3.63 % ® O @ mncognito

® HMI Name: Date/Time: & admin
\\ cMT3072XH

EasyWeb 2.0

@ sysen EasyAccess 2.0

T3 Network

Connection

@ o

Status: 2 (Connected)

& Project
= Data
Fealures

&% Weincloud Hardware key:

® EasyAccess 2.0 Error code: 0

SessionID: 0
Password: 0
Version: 2.16.5

Domain Name:

Weincloud » Dashboard

In this page the current subscription status of Dashboard can be viewed.

192.168.
® HMI Name: Date/Time: -  admin
\\ cMT3072XH
EasyWeb 2.0
0 Dashboard
System
T3 Network
Region: Global
Domain: weintek_fae
Status:

Expiry Date: 1970-01-01

Action: < Manage on Weincloud

® Dashboard QR Code:

e

UMO020001E_20240807 Copyright© 2023 WEINTEK 1IOT LTD. All rights reserved. 13



Administration » System Password

There are four different levels of password protection: System Setting, Update Project, History, and
User, and in this page the user can change the passwords. The default passwords are 111111.
[System Setting]: This is the highest level. It has an access to change all system settings, download,
upload project, back up historical data, or change passwords for other levels.

[Upload Project]: This level can download, upload project, and back up historical data.

[History]: This level controls FTP access and it can back up historical data.

[User]: This level can operate cMT X projects via cMT Viewer. Other three levels above can all do
this.

@ aur x  + v - o X

&« C { A F=2 | bps//192.168.2.119/admin/account/password 2 B & » O @ :

© cMT3152X
\‘ gﬁsy‘u"lsb 20 b

o System
g Network

System Password

| Please select identity to edit password
B Poject

System Setting

Current password:

®

New password:

© Administration

®  System Password

Confirm new password:

Submit Reset

System Setting
Update Project
History

User

UMO020001E_20240807 Copyright© 2023 WEINTEK 1IOT LTD. All rights reserved. 14



Administration » Security

x  + v

192.168.2.13 ‘ a @ e
® cMT3072XH - HMI Name: Date/Time: 2 2 admin
\‘ EasyWeb 2.0 3
e Security
@ iy Force HTTPS .

Auto block if failed login attempts reaches the limit

Allow site embedding a
Allow CORS requests [ @)
Password Strength Rules Reset m

Enable password strength rules

Minimal password length

Include numbers

[Web Security]

Encrypt communication with EasyBuilder Pro, block the account when the number of failed login

attempts reaches the limit, or allow this web page to be embedded.

Force HTTPS a

Auto block if failed login attempts reaches the limit

Allow site embedding

8

Allow CORS requests

8

[Password Strength Rules]

Set password strength rules that EasyWeb uses to determine whether a password is valid.

UMO020001E_20240807 Copyright© 2023 WEINTEK 1IOT LTD. All rights reserved.
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Password Strength Rules Reset
Enable password strength rules

Minimal password length

Include numbers

Include mixed cases

Include special characters

[Password Expiration]

Set the password expiration policy.

Password Expiration Reset

Enable password expiration

Validity period

days
Enforce password update
Administration » OS Update
The OS can be updated by using EasyWeb 2.0.
\\0 SZEEZ%XH HMI Name: DatefTime: Q L admn v

o System OS U pdate

T3 Network

OS Update: Update =

® OS Update

During the update process, please do not turn off the HMI.

UMO020001E_20240807 Copyright© 2023 WEINTEK 1IOT LTD. All rights reserved. 16



3¢ Updating

© © ®

Prepare OS Update Upload OS Image Update OS

© Please wait until update has completed

Once the update is complete, the system will display the following window.

© Update Completed X

© © ©

Prepare OS Update Upload OS Image Update OS

@ 0S Update has completed!

The window below may appear for the following reasons:
1. Incompatible OS version.

2. |IP address changed after OS update.
3. The OS update process took too long.

Check the device X

Unable to verify the OS update result. Please check the device and verify the OS
update result.

Common reasons:

OS is updated to an incompatible older version
IP address is changed after the OS update

OS update takes longer than expected (3 min.)

If the device is unresponsive, please contact our distributors or via our website.

UMO020001E_20240807 Copyright© 2023 WEINTEK 1IOT LTD. All rights reserved. 17



Chapter 2 How to Use Webview

2.1 Overview

cMT X Series HMI can be monitored and controlled using an internet browser (Windows Edge,
Chrome, or Firefox). Up to 4 users can log in simultaneously.

2.2 Enabling Webview

Log in Easyweb 2.0, open Webview Setting page and toggle on [Enable]. In this page, whether a
password is required for logging in Webview can be set.

Force HTTPS: Enabling this will make Webview use HTTPS.

Use same HTTP port as EasyWeb: Enabling this will make Webview use port 80 to connect to the

VNC server when accessed via HTTP.

AN +

192.168.2.13 % O @ =mstum i

- HMI Name: Date/Time: Q > admin
\‘o cMT3072XH =
EasyWeb 2.0 3

@ s WebView Setting Web\View w
T Network

Enable c
= Project

Force HTTPS ()
@ Features Use same HTTP port as EasyWeb
® WebView Setting

Use WebView as homepage

User List 0 A Control Only View Only

Automatic Login © Disabled Control User View User

Control User Change password &

View User Change password (&

2.3 Log In Webview using an Internet Browser

Step1l. Open internet browser and enter HMI's Webview address (e.g.: 192.168.2.121
/app/dashboard). In Webview settings, if “Set as homepage” option is selected, then
simply enter the IP address (e.g.192.168.2.121). Webview interface opens after entering
the password.

UMO020001E_20240807 Copyright© 2023 WEINTEK 1IOT LTD. All rights reserved.
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S vt x  +
& C A F=2 | 192168.2.121/app/login?auto=stop - % ®% O @ B =@ :

Control Mode

Step 2. The HMI screen is displayed in the browser window. Certain HMI screen resolutions may
exceed the browser window size. When this happens, to change the view area, drag the
white frame that represents browser window in the lower-right corner and move within
the gray area that represents HMI screen.

[=[@] % ]
S oMT x 4+
C A F=2 | 192.168.2.121/app/dashboard - % 4 OH B =@ :

VNC Viewer run on HMI allows remote monitoring devices with VNC Server installed for
flexible operation.

Step 3. The toolbar that opens by clicking the three-line icon in the upper-left corner of the
window is shown below. From left to right, the toolbar is separated into three groups of
items.

UMO020001E_20240807 Copyright© 2023 WEINTEK 1IOT LTD. All rights reserved.
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In the first group, the HMI screen can be resized to fit in the browser window, or
displayed with HMI’s actual screen resolution.

In the second group, the position of the icon that opens the toolbar and the dragging
panel that moves the view area can be changed.

In the third group are the system settings icon and the logout icon.

8 B

0 Note

B When “Set as homepage” is selected in Webview, the Webview interface can be opened by
directly entering HMI IP address. When login password is forgotten, please enter

https://HMI IP/admin to return to the default system settings page. This prevents the

situation where Webview functions cannot be used once password is forgotten.

2.4 When Webview Doesn’t Open

When a login attempt fails and the page below shows, try the following ways to troubleshot.

1. Check whether Webview is enabled for the HMI.

2. Check whether the browser supports Webview, and please use recommended browsers such as
Windows Edge, Chrome, or Firefox.

3. Maximum number of users may be exceeded (4 users at a time).

SEIES
S T X 4+

< G ® F=2 | 192.168.2.121/app/dashboard # % O | B =@ :

CONNECTING

T

If it takes a long time to connect.

Possible causes :

1. Webview feature is disabled on this HMI.

2. This browser does not support Webview.

3. Maxinum connections for Webview has been reached.

Windows is a trademark or a registered trademark of Microsoft Corporation in the United States and/or other countries.

CODESYS® is a trademark of CODESYS GmbH.

Other company names, product names, or trademarks in this document are the trademarks or registered trademarks of their respective companies.
This document is subject to change without prior notice.
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