Create an EasyBuilder Pro Project

3. Create an EasyBuilder Pro

Project

This chapter explains the basic steps to create an EasyBuilder Pro project.
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3.1. Overview

The following is the process of creating a project.

1.
2.
3.
4.

Create a new project file.
Save and compile the project file.
Run On-line or Off-line simulation.

Download the project file to HMI.

The following describes each process.

E Click the icon to watch the demonstration film. Please confirm your internet connection

before playing the film.

3.2. Create a New Project File

1.
2.

3.

Launch EasyBuilder Pro and open a new project file.
Select a model and select [Use template] check box.

@ New

New Project

Open

Model: | 4 I8 iP Series
MT80S1iP (480 x 272)
MT8051iP (480 x 272)
MT6071iP/MT8O71iP (800 x 480)
MT6103iP (1024 x 600)
MT8102iP (1024 x 600)
MT6102iQ (1024 x 600)

4 @ eMT Series
eMT3070 (800 x 480)

£eMT3105 (800 x 600)

eMT3120/eMT3150 (1024 x 768)
4 B iE Series
MTB8050iE (480 x 272)
MT6070iE (800 x 480)
MT6071iE (800 x 480)
MT8070iE/MT8100iE (800 x 480)
MT8071iE/MT8101iE (800 x 480)
MT8073iE (800 x 480)

m

[¥] Use template (template_800x600.emtp)

[Un(cmpress Projé:t] [.L, Demo Projectl

eMT3105

Orientation :

[ Portrait

Click [New] button in the Device tab and select a device.
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System Parameter Settings =]
Printer/Backup Server l Time Sync./DST | e-Mail | Recipes | Cellular Data Network
Device | Model | Gemeral | SystemSetting | Security | Non-ASCIIFonts | Extended Memory
Device list : What's my IP ?
Name Location ~ Device type Interface IIF Protocol

(3 Local HMI Local HMI lLocal  [em73105(800..[- |- |

<« w »

[ New... ][ Delete ][ Security... ]

4. Configure parameters.

Device Properties

Name : | Mitsubishi FX0S/FXON/FX1S/FXLN/FX2
) HMI @ PLC

PLC type : [ Miteubishi FEO3/FXON/FL L 3/FH 1 N/FES | » ]

[\l’.l.‘-ﬂ], MITSUBISHI_FX0OM.230

PLCUF : [Rs-485 4W -

* Support communications between HMI and PLC in pass-through mode
* Gt LW-9903 to 2 to enhance the speed of download/upload PLC program in pass-through mode

COM : (COM1 (9600,E,7,1) Settings...

PLC default station no. : o

[C] Default station no. use station no. variable

[T use broadcast command

Interval of block pack (words) :

Max. read-command size (words) @ 22

Max. write-command size (words) : |32

I 0K ] [ Cancel
5. A new device is added to the [Device List].
(= > =
System Parameter Settings
|  Printer/Backup Server | TimeSync/DST | eMail | Recipes |  Cellular Data Network
Device | Model | Genersl | SystemSetting | Security | Non-ASCIIFonts | Extended Memory
Device list : What's my [P ?
No. Name Location Device type Interface I/F Protocol
il Local HMI Local eMT3105 (800 ... -
» Local PLC1 |Mitsubishi FXO... Mitsubishi FX0... |COM 1 (9600,E... |RS485 4W

6. Create an object, for example, a Toggle Switch, and then set the address.

D\'WE!NTEK EasyBuilder Pro V6.10.01



Create an EasyBuilder Pro Project

7.

[New Toggle Switch/Bit Lamp Object @
General | Security | Shape | Label |

Comment :

() Bit Lamp @ Toggle Switch

[V] ReadMrite use different addresses

Read address
PLC : [Mitsubishi FXOS/FXON/FXIS/FXIN/FX2 <[ Settings...
Address: (g -] 0 i
[ Invert signal
Write address :
PLC : [Mitsubishi FXOS/FXON/FX I S/FE1N/FR2 - | Settings..
Address : [Y v] 0 \
[ Write when button is released
Attribute

Place the object in the edit window. A project is now created.

EasyBuilder Pro : EBProjectl - [10 - WINDOW_0101 fo &=
File B &= « » ;: BEEUEE Project  Object Data/History View  Tool - 8 X &
= Y v 3] | O8] | ~ - > ] i ~ |5 -

@ % A-D 9@ @ 5 i : AdobeDevanagari 5 Bl s> <3 4l
— fore) BEE--EEE- A A7 A T
Paste System = £ o3 ¥ s 1
Parameters e eoncit o B 8 === A L1/L2 13 L4
Clipboard Editing Object Arrange Font State/Language

Windows v X dq 10 - WINDOW_ 010 X 3

jobjkal '! ‘|I|I|I|I|I|I|I|I|IP|C1|I|I|I|I|I|I|I|I3Pﬁxl|l|l|||l|l|l-l|;ID|C||l|I|I|IxI|I|I|I|AP|01|I|I|I|I|I||I|I|||5IO|0||I|I|I|I|||I|I|Ixﬁlonol|I|||I|I|I-I|I|I|.IO|OI|I|I|I|I|I|I|I|I|I|!

| 3 : Fast Selection - 1

4 : Common Window @
5:PLC Response

6 : HMI Connection

7 : Password Restriction

8 : Storage Space Insufficient
9:Backup

*10: WINDOW_010

00

00

00

|.|.|JP.l.l.|‘.|.|.|‘.|‘.|‘.|Jl’.u|‘.|.|-|J|‘.|.:.|JF.|.|.|‘.|.|.|.|‘.1.|.|‘]‘.|,|‘.|.|‘.|J|‘.|.|.|‘.|

00

3.3. Save and Compile the Project File

1.
2.

RWE!NTEK

In EasyBuilder Pro toolbar click [File] » [Save] to save the .emtp file.

In EasyBuilder Pro toolbar click [Project] » [Compile] to compile .emtp file as .exob file,

which could be downloaded to HMI. This also checks if the project can run correctly.
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0 Note

B  For cMT / cMT X Series models, the project file e
extension is .cxob.

3. To use multiple languages, all languages must be

xtension is .cmtp, and the compiled file

configured in Label Tag Library first.

When downloading the project to HMI, select the needed languages only. A successful

compilation is shown in the following figure.

Compile
Project name : C:\Jsers\Janecheng'Desktop\EBProjectl.cmtp

CX0B file name : C:\Users\Janecheng\Desktop\EBProject1. cxob

CXOB password : Settings. .. (uzed in decompiler)

[ becompilation is prehibited [ Disable HMI upload function

Select the languages used on the HMI
Startup language after red

Language 1

Treat the use of unsupported tags as @ |Error -

X5

ownloading the project : Language 1 -

Double-dlidk a message to modify the attributes of the object in question

Font Management...

| [C1Build font files

Close

3.4. Compile and Quick Compile

The [Compile] and [Quick Compile] modes can be selected in the Compile window. To compile

a relatively large file in which only a few windows are
be used to save compilation time.

Compile:

Compile the whole project file.

Quick Compile:

modified, the Quick Compile mode can

Only compile the modified window or event log. When one of the records in the event log is

changed, the whole event log will be compiled.
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@ Note

B [f the project file is compiled for the first time, the Quick Compile mode is not supported.

B In a project file, when its system settings, picture library, sound library, or label library is
modified, then Quick Compile mode is not supported for the first compilation after
modification.

B The whole project file must be compiled before it is downloaded to HMI.

B Utility Manager does not support the project file compiled using Quick Compile mode. To

download a project file using Utility Manager, please compile the whole project file first.

3.5. Run On-Line or Off-Line Simulation

FII!

s
— Off-line simulation: Simulate project operation on PC without the need for connecting

any device.

FII!

h— On-line simulation: Simulate project operation on PC without downloading the project
to HMI. The PLC is connected to PC, please set correct parameters.

@ Note

B (iE/XE/eMT Series) When using On-line Simulation on PC, if the target device is the PLC
directly connected to PC, there is a 10-minute simulation limit.
B (cMT/cMT X Series) When using On-line Simulation on PC, the monitoring time is limited

to one hour and a prompt window pops up every 15 minutes.

3.6.cMT Viewer

This program connects to cMT Series models via network. To run this program, execute
cMTViewer.exe under installation directory. Or, in EasyBuilder Pro toolbar, click [Tools] » [cMT
Viewer].

E Click the icon to watch the demonstration film. Please confirm your internet connection

before playing the film.
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2, <M Viewer (=@ =]

2017-02-09 19:21:24

3.7. Download the Project File to HMI

The following explains four ways to download the project file to HMI.

@ Note

B For cMT-SVR, only the way described in 3.6.1 is available.
B When download project file to HMI using mini USB cable, please do not connect PLC
simultaneously, in order to avoid noise from PLC interfering with HMI.

m Click the icon to watch the demonstration film. Please confirm your internet connection

before playing the film.
3.7.1. Configure in EasyBuilder Pro

1. In EasyBuilder Pro toolbar, click [Project] » [Download]. Make sure that all the settings are
correct.
2. Select [Ethernet], set password and HMI IP.

’__IbWE!NTEK EasyBuilder Pro V6.10.01
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eMT, iE, XE, mTV Series

Download (PC->HM)

)

Password/Port no. of download/upload :

@ Ethernet

4 7 P HMIName b
IP: 10.7.139.86 -
Font files Use EasyAccess 2.0 What's my [P7

Diagnostic tool

Runtime = Necessary if update runtime or execute download first time.

[] Use user-defined startup screen

[] Use system settings file

Synchronize HMI clock with PC

[T] Delete user-defined startup screen

[T] Reset recipe (RW, RW_A) [T Reset event log

[C] Reset recipe database [] Reset operation log

[T] Reset data sampling
[C] Reset string table

Reboot HMI after download
[] Automatically using current settings to download after compiling

cMT, cMT X Series

Download (PC->HMI)

@) Ethernet

4 7 P HMI Name

IP: 1071

Froject Checksum : 9ee5836¢3331ab23569a5a011d7e5h7

[ Runtime = Necessary if update runtime or execute download first time.

[ Use system settings file

Synchronize HMI clock with PC
[] Reset recipe (RW, RW_A)
[ Reset recipe database

["] Automatically using current settings to download after compiling

39.86 -

[] Reseteventlog
[C] Reset operation log
[] Reset PRW on HMI

Password/Port ne. of download/upload :

3

What's my [P7

["] Reset data sampling
[C] Reset string table
and all eMT Viewers

o e bomioss || swp
Setting Description

Font files

Download the font used in the project to HMI.

Runtime Select the check box to update the HMI kernel
programs. If this is the first time downloading file or
EasyBuilder Pro version is updated, please download
the firmware before downloading files to HMI.

EasyAccess 2.0 Download EasyAccess 2.0 driver to HMI. (This option

is available only for MT8000iE models. For other

models, EasyAccess 2.0 will be automatically

downloaded.)

Use user-defined
startup screen

Download the specified .bmp image file to the HMI

as the startup screen. For cMT/cMT X HMI, please

see chapter 5.4 General Settings in this user manual

for more information on updating the startup screen
on the HMI.

Use system settings
file

hardware settings.

Download the system settings file to update

Synchronize HMI
clock with PC

downloading project file.

Synchronize HMI time with PC time when

Delete existing user
accounts, e-Mail
contacts and SMTP
settings

Select the check box to delete existing user
accounts, e-Mail contacts or SMTP settings before

downloading the project. This setting is only

effective when one of the following settings is

I__| WE!NTEK
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enabled:

1. [System Parameters] » [Security] » [Enhanced
security mode] » [Use existing user accounts on
HMI first (if existed), Othrewise, use settings
below].

2. [System Parameter s] » [e-Mail] » [Use existing
user accounts on HMI first (if existed),

Othrewise, use settings below].

Reset recipe/
event log/

data sampling/
recipe database/
operation log/
string table/
user-defined
startup screen

The selected files will be erased before
downloading.

Reboot HMI after
download

HMI will reboot after the downloading process is
done.

Automatically
using current

The system will compile the project and download it

settings to to the latest target HMI. The way to enable this
download after L . . .
compiling function is described in the following part.

[Automatically using current settings to download after compiling]

If this check box is selected, EasyBuilder Pro will compile the project and download it to the

latest target HMI.

1. In EasyBuilder Pro toolbar, click [File] » [Preferences].

2. Select [Automatic save and compile when download and simulate] check box.

I__| WE!NTEK
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Preference
Project
Display [¥] Automatically save and compile the project when download and simulate
Grid [7] Generate backup of project file before save
Library [] Automatically make used pictures and shapes into the project library

[] Save AutoRecover information

[ OK J [ Cancel

3. In EasyBuilder Pro toolbar, click [Save] and then [Download].

4. Inthe dialog box, select [Automatically using current settings to download after
compiling] check box.

5. Click [Download].

6. When finished, next time when [Download] is clicked, EasyBuilder Pro will automatically

compile and download the project to the latest target HMI.
3.7.2, Use HMI Name

1. Go to [System settings] on HMI and then set HMI name first.

.Systern settings

Network\ Time,"Date‘| Securit  HMI name\gietting\wg‘\

HMI namel

i Cancel | : Apply | 0K “~ ¢
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2. On PC, select the HMI name and start downloading. To use [Search], enter the HMI name

first to search for the HMI. [Search all] searches for all HMIs in the same subnet network.

[]use user-defined startup screen

[]Use system settings file

[¥] synchronize HMI dock with PC

|| Delete user-defined startup screen
[V Reset recipe
[¥|Reset recipe database

[7] Reboot HMI after download
A

[¥|Runtime * Necessary if update runtime or execute download first time.

[V|Reset event log
[V Reset operation log

utomatically using current settings to download after compiling

Download (=3
©) Ethernet Password/Port no. of download/upload :
‘ 4 /s I/' HMI Name 3
HMI: je7 v
Search All
[¥]Font files [V] Use EasyAccess 2.0 What's my IP?

[V|Reset data sampling
[V|Reset string table

I__| WE!NTEK
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3.7.3. Use USB cable

Download (=3

@ USB cable Password : | Settings... ’

[V]Font files
[¥|Runtime *Necessary if update runtime or execute download first time,

[ Use user-defined startup screen

[ Use system settings file

[ Delete user-defined startup screen
[¥]Reset recipe [V|Reset event log V|Reset data sampling
[¥] Reset recipe database [¥]Reset operation log [V]Reset string table

|¥|Reboot HMI after download

[7] Automatically using current settings to download after compiling

| Download ] Stop Exit ’

Select USB cable to download project to HMI. The way of setting is same as “3.6.1 Configure in
EasyBuilder Pro”. Before downloading via USB cable, please make sure the USB driver is

installed. Go to [Computer Management] » [Device Manager] to check if USB driver is installed.

If it is not installed, please refer to to install manually.

3.7.4. Use USB Drive or SD Card

The following explains how to download project file by using USB drive or SD card.
1.  On EasyBuilder Pro toolbar click [Project] » [Build for SD card / USB disk download].

Browse for the project file and then click [Build], the file for download will be generated in
the connected external device.
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USE Disk/CF Card/SD Card Data (=3

Select the folder to save download data :

i

Use system setting (OS5 version 20131106 or later supports only)
System setting file location =

[ Build ] [ System Settings...
2. Insert an external device to HMI.
3. Select [Download] on HMI and enter password.
Download/Upload
S Powniosd settngs I
Upload Password: ||
Restart project and exit ‘
M Download project files
Load System Setting |7 Download history files
cancel l_ Clear history files
Stop after download/upload
Time remaining 4

4.  After password is confirmed, it will show the directories in the external device. (pccard: SD
Card; usbdisk: USB Drive)

[Pick abirectory P4
Directory: Jusbdisle/disk_a_1

=¥ pecard
usbdisk

OK "r Cancel

5. Select the directory that contains project, and then click [OK] to start downloading.
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@ Note

B Please select the parent directory of the generated files when downloading. For the
structure above, please select disk_a_1, not mt8000ie.

B You may click [System Settings] to save the hardware settings configured in EasyBuilder
Pro into SD card or USB disk, and then download the settings file to HMI. See “4 Hardware
Settings” for more information.

E Click the icon to watch the demonstration film. Please confirm your internet connection

before playing the film.
3.8. Upload the Project File from HMI

1. On EasyBuilder Pro toolbar click [File] » [Upload].
2. Set HMI IP, HMI model, project location and project name, and then click [Upload].

Upload @I
@ Ethernet ) USB cable Password/Port no. of download/upload :
4 P Name I
IP: 192.168.1.100 -
W hat's moy TP 2
HMI model : | eMT3070 >
Project location : C:\EMTP1.excb
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