Window Operations

6. Window Operations

This chapter describes different types of windows and how to create, set and delete a window.
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6.1. Overview

A window is a basic element in a project. With a window, all kinds of information like objects,
pictures, and texts can be displayed on HMI screen. In total, 1997 windows numbered from 3 ~
1999 in EasyBuilder Pro can be built and edited.

6.2. Window Types

There are 4 types of windows, each with different functions and usages:
® Base Window

® Fast Selection Window

® Common Window

® System Message Window

6.2.1. Base Window

The most frequently used window, except for main screen, it can also be:
® A background of other windows.

A keyboard window.

A pop-up window of Function Key object.

A pop-up window of Direct Window and Indirect Window objects.
A screen saver.

0 Note

B Base Window should be in same size as the HMI screen. Therefore, the resolution of the
base window should be set to the resolution of HMI.

6.2.2. Fast Selection Window

Window no. 3 is the default Fast Selection Window. This window can co-exist with base
window. Generally, it is used to place the frequently-used buttons on the lower-left side or the
lower-right side on the screen. Please create window no. 3 first, and set the relevant properties
in [System Parameter Settings] » [General] tab. Apart from showing or hiding fast selection
window with the button on the screen, there are system registers to do so:

[LB-9013] hide (set ON)/show (set OFF) Fast Selection window

[LB-9014] hide (set ON)/show (set OFF) Fast Selection button

[LB-9015] hide (set ON)/show (set OFF) Fast Selection window/button

@ Note

B cMT/cMT X Series does not support Fast Selection Window.
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6.2.3. Common Window

6-3

Window no. 4 is the default Common Window. Objects in this window will be displayed in

other base windows, not including pop-up windows. Therefore, the common objects in

different windows are often placed in common window.

When operating HMI, select [Function Key] » [Change common window] to change the source

of common window.

In menu [File] » [Preferences] » [Display] select whether or not to [Display Common Window

objects on Base Windows] when editing a project. This can avoid overlapping objects in base

window with objects in common window.

Preferences @
Display Object 1D Display Object Address
Font size : Text color : I ¥
[¥] Background Background color : ﬂ
The number of displayed addresses :
Display Common Window objects on Base Windows
[] Display Underlay Window objects on Base Windows
|| using function key to make shape lbrary object
Automaticaly save and compile the project when download and simulate
[C] Generate backup of project file before save
[T Automatically make used pictures and shapes into the project library
Save AutoRecover information
Every minutes

6.2.4. System Message Window

Windows No. 5, 6, 7, 8 are the default System Message Windows:

E@EO Device No Response

Close

& railed Connection to
D Remote HMI

Close

' Password Protected!
Access Denied!!

Close
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Window No. 5: Device No Response

When the communication between device and HMI is
disconnected, this message window will pop up
automatically right on the base window currently opened.
This window can be disabled by system registers.
Window No. 6: HMI Connection

When failing to connect HMI with a remote HMI, this
message window will pop up automatically.

Window No. 7: Password Restriction

When attempting to control an object without
authorization, this window may pop up as a warning
depending on the settings of the object.
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Window No.8: Storage Space Insufficient
» When HMI flash memory, USB disk or SD card run out of
Storage Space Insufficient !! . . .

storage space, this message window will pop up

@ automatically. (When the memory space is under 4 MB)

The following system registers can be used to check the free memory space in HMI, USB disk,
or SD card:

[LW-9072] HMI current free space (K bytes)

[LW-9074] SD current free space (K bytes)

[LW-9076] USB disk current free space (K bytes)

To check if there is sufficient storage in the devices, the following system registers can be used.

These addresses will set ON when the space is under 4 MB.
[LB-9035] HMI free space insufficiency alarm (when ON)
[LB-9036] SD card free space insufficiency alarm (when ON)
[LB-9037] USB disk free space insufficiency alarm (when ON)

|:)?For more information, see “22 System Registers”.

The text shown in windows no. 5 ~ 8 can be edited for easier reference.

@ Note

B For eMT/iE/XE/mTV models, a screen can display up to 24 pop-up windows simultaneous
including System Message Window, Direct Window and Indirect Window. For cMT/cMT X
Series, the number of pop-up windows is not limited.

B The system does not allow opening the same window (including overlay windows) with
two Direct / Indirect Windows in one base window.

B  Windows no. 3 to 9 are used by the system only, and windows no. 10 to 1999 can be
edited based on actual usage.

6.3. Create, Set, and Delete a Window

Check the existing windows in [Windows Tree].

[Windows Tree] displays window numbers and window names. Opened windows are marked
with T icon. Press the (+) sign to see the object ID, address and description of the objects
used in this window.

[Window preview] displays the thumbnails of windows.
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Windows Tree v

™ 3: Monitor Mode

™ 4 : Common Window
[ 5: Device Response
[ 6: HMI Connection

[ 7 : Password Restriction

] 9:Backup
-] 10 : WINDOW_010
- FK_0 (Back)
- FK 1
- FK 2
L FK 3
11
12
13
14
15
16
17
18
19
20
21
22
23

[T 8: Storage Space Insuffici...

6.3.1.  Creating and Setting a Window

In windows tree right click on a window number then select [New].

RWE!NTEK

Windows Preview
0003

Monitor Mode
0004

Commeon Window
0003

Device Responss
0006

HMI Connection
0007

Password Rastriction

0008

Storage Spacs Insufficient

0008

Backup
0010

WINDOW_010

7]
| X

m
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Window Settings

Name @ WINDOW_010

Window no. : 10

Size
Width : 800

Background

Color : v

[T Filled

Height : 480

Color : G ~

Frame

Underlay window

Bottom : 11, Window_D11 -]

Middle : [None M ]

Top: [None - ]

Popup window
Start position

¥: 0 v. 0 [¥] Monopaly [¥] Title bar

Macro

Open : [[ID:UUO] macro_0 v]

Cyde : |Disable -

Close : [Disable T ]

Setting

Description

Name

The name appears on the title bar and also in windows tree.

Window no.

Can be 3 to 1999.

Size

Set the window size in accordance with the HMI resolution.

Underlay
window

Underlay Window can be seen as an extra Common
Window. When designing the project, some commonly
used objects are used in some windows but not all. These
objects can be placed in underlay window.

Each base window can set three underlay windows as
background, from [Bottom] to [Top]. The objects in underlay
windows are displayed in this order in base window.

Pop-up

window

Base window can also be used as a pop-up window. Use [X]
and [Y] to set the coordinates indicating where in the screen
will this base window pop up. The origin of the coordinates
is the upper-left corner of the window.

Monopoly

If the option is selected, when the base window pops up, no
operations of other pop-up windows and background
windows are allowed until the monopoly window is closed.
If a base window is used as a keyboard window, “Monopoly"
is automatically enabled.

Title bar

If the option is selected, a title bar appears on a system
message window. This feature is only available for system
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message windows no. 5 to no. 8.

Macro Select the macro to be executed when the window opens or
closes, or the macro to be executed periodically (each 500
ms).

Please build the macro in advance.

@ Note

B The objects in underlay window cannot be edited from the base window that displays
them. To edit those objects, please open the underlay window where they are located.

B When the window number of the underlay window used by the base window is identical
to the pop-up window, the pop-up window is disabled.

B When base window and pop-up window use the same underlay window, the objects in
the underlay window cannot be displayed in pop-up window.

El Click the icon to watch the demonstration film. Please confirm your internet connection

before playing the film.

Or, from the main menu click [View] » [Open Window] and then click [New] and select the type

of the window and click [OK].

Open Window
Nao. Window name Size
E] Fast Selection 100,450
4 Common Window 800,480
5 PLC Response 320,100
6 HMI Connection 320,100 Seitings:
7 Password Restriction 320,100
8 Storage Space Insufficient 320,100
*10 WINDOW_010 g800,480
50 Keypad 11 - Integer 275,280
51 Keypad 12 - Integer 275,280
52 Keypad 3 - Integer 200,170
53 Keypad 4 - Integer 304,213
54 Keypad 5 - Integer 160,230
55 Keypad 6 - Integer 241,331
56 Keypad 7 - HEX 306,223
57 Keypad 8 - Floating 198,220
58 Keypad 9 - Numeric 248,248
60 ASCII Middle 576,240
61 ASCII Srmall 480,200
62 ASCII Upper M 576,240
63 ASCII Lower M 576,240
64 ASCII Upper § 480,200
63 ASCII Lower 5 480,200
Exit

Ways to call up [Window Settings] dialog:

® Right click on the window number in the windows tree and select [Settings].
® In[View] » [Open Window] select the window then click [Settings].
® |nthe window, right click when no object is selected, and select [Attribute].

6.3.2. Open, Close, and Delete a Window

The ways to open an existing window:
® Double click on the window number in the windows tree.
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® Inthe windows tree, select the window number, right click, and then select [Open].
® |n[View] » [Open Window] select the window number and then click [Open].

The ways to close or delete an existing window:

® |nthe windows tree, select the window number; right click, and then select [Close] or
[Delete].

® |n[View] » [Open Window] select the window number and then click [Delete].

6.4. Window Transparency

The Opacity setting in the View tab is used to adjust transparency effect of the common
window, overlay windows, and window layers.

-

EasyBuilder Pro (=

[View] > [Layer Opacity] is set to 50% by default for window layers,
I % common window and underlay windows to enhance object
visibility in current window during editing.

Lo J

As shown in the following screenshots, greater Opacity makes the object in the relevant
window more visible.

\' Q () Zoomln Q' Q & Zoomln

: (2) ZoomOut e ©) ZoomOut
Opacity Zoom Center Opacity Zoom Center
30% »  75%. (i) FittoWindow  View » 70% -« | 75%. ciy FittoWindow  View .
i 0% 0%
10% - 10% J—
1 J,JJL['??{J,I,!J,l,!lfﬁjjI,I,I”I”IlI ) e 8 B
20% 20%
v 30% 30%
40% 40%
50% 50%
60% 60%
70% v 70%
80% 80%
90% 90%
100% 100%

Additionally, the cMT / cMT X Series models support setting window transparency. This setting
is applicable for popup windows, Direct / Indirect Windows, and keyboard windows. The

settings dialog box and the effect are shown in the following screenshots. Greater transparency
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can make the object on the base window more visible when it is covered by the popup

window.
W'lﬁowﬁeﬂings
Mame : WINDOW 010
wodonno. (1|
Size
Width : 1024 Height: 748
Backaground
Color : I:IIV|
Transparency : D 20%s
* [Transparency] is used only on popup, directfindirect and keyboard windows.
Underlay window
Bottom : [None -
Middle : [Nane -
Top:lm vl
Popup window
[¥] Monopoly
Macro
Open l vl
Cycle l vl
Close l vl
ok || cancel |
Example

Setting transparency to 40%:

Setting transparency to 90%:

[\& WE!NTEK
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6.5. Editing Tips

EasyBuilder Pro provides a user-friendly interface with which users can easily edit projects. The

following are some editing tips.
6.5.1. Non-display Area, Select Tool, and Hand Tool

As shown in the following screenshot, two areas can be found in the editing window: editing
area and non-display area. The non-display area refers to the area outside the editing area (the
one in the middle). Objects placed in the non-display area will not be visible on HMI, and
communication with devices continues. The invisible objects such as Meter, Time-based Data
Transfer, or Text objects used for comments can be placed in this area to avoid overlapping
with other objects in the editing area, which adds difficulty to project editing. The objects
placed in the non-display area remain effective.
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4 10 - WINDOW 010 %

| PYCTETEIRICE i YT TYPRICE, i P PPN YCIRICYyc AOPRPYAUYPCIYICYy c MPRIYRPRIURYTOYsci APRIYTRTRINININY;ci APEIRTLININIUINY c NTTTITIEIRAIO

h‘ Select Tool
Clicking this icon in the toolbar changes the cursor to the Select Tool. Select a

single object by clicking it, or select multiple objects by clicking on an empty
part of the editing screen and then drag a box around the objects.

4‘"}2 Hand Tool
Clicking this icon in the toolbar changes the cursor to the Hand Tool. The Hand

Tool allows moving through the project screen by simply left clicking the mouse

and dragging anywhere.

6.5.2. Ruler

| :1|I|I|I|I|I|Illllllpﬂllllllllllll|I|I|:F|:1|I|I|I|I|I|I|I|I|_:P|:1|I|I|I|I|I|I|I|I|49|:1|I|I|I|I|I|I|I|||5F|:4|I|I|I|I|I|I|I|I|59|:1|I|I|I|I|I|I|I|I|-P|:4|I|I|I|I|I|I|I|I|I|
Selecting [View] » [Ruler] adds rulers to the top and left of the editing screen. Guides can be
added from the ruler by right click on the ruler. Objects will automatically snap to the guides

when moved or resized.
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4 10-WINDOW010 x|

q|I|IlIlI|IbllI|lllmlllIllllllllllllmnllllt

Setting Description
Delete Delete the guide.
Edit

Settings

Add or delete multiple guides.

Selecting [File] » [Preferences] » [Grid] opens the following window for setting the color or style
of the Guides.
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Project

Display

Grid
Library

B
Grid
Spacing
X(4-600: 20 Y (4-600 1 20 =
[ Display [ snap [T Fix all objects
Guides
soie (=]

6.5.3. Quick Copy

Quick copy can be carried out by pressing and holding Ctrl key on the keyboard while an object

is selected, and then drag the cursor to a new location where the object will be created.
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